dccifd/dccd and systemd

Christian Balzer chibi@gol.com
Tue Oct 4 02:01:04 UTC 2016


Hello,

just in case this wasn't answered in private and I missed it:

On Mon, 07 Sep 2015 13:04:35 +0200 Michael Artz wrote:

> Hi all,
> 
> up until now we used to start both dccifd and dccd by just linking the 
> /var/dcc/libexec/rcDCC into /etc/init.d.
> 
> After debian 8 switched from init to systemd this no longer works at 
> system startup. Neither dccifd nor dccd are started by systemd at boot 
> time. Starting dccifd or dccd manually by calling the script after the 
> system is up works without problems, though.
> 
> Does anyone have a similar setup with systemd? How did you insert 
> /var/dcc/libexec/rcDCC into systemd so dccifd and dccd are started at 
> boot time?
> 

I run a pure Debian shop and have several MX servers in various states,
Wheezy, fresh Jessie install with SysV init and fresh Jessie install with
systemd.
All of these work fine and as expected.

Yesterday I upgraded an older backup MX from Weezy to Jessie and found the
same thing, DCC wouldn't start at boot time (the status was "file not
found", but a manual "systemctl enable dcc" and consequent "start" would
work later on.

After fumbling around for a bit it turned out that actually copying the
rcDDC script (not symlinking it) to init.d fixed that.
However that wasn't necessary with either fresh pure SysV or systemd
Jessie installs.

As it turned out, this is obviously caused by the older systems having a
separate var partition, whereas all the newer ones (SSD based) are on a
single (/ only) file system. 

So that's why copying the rcDCC fixed it, just another one of those
fantastic systemd features (/sarcasm). 

Regards,

Christian
-- 
Christian Balzer        Network/Systems Engineer                
chibi@gol.com   	Global OnLine Japan/Rakuten Communications
http://www.gol.com/


More information about the DCC mailing list

Contact vjs@rhyolite.com by mail or use the form.