sendmail not communicating with dccm

Michael Grant mgrant@grant.org
Sun Jul 20 13:04:40 UTC 2014


1) I have this in my sendmail.mc <http://sendmail.mc/> file:

FEATURE(dcc)dnl

and I know sendmail is aware of the socket at /var/run/dcc/dccm because
when I change permissions on that or remove it, sendmail complains on
restart.

2) I have tried running dccm in debug mode like this:

# /usr/lib/dcc/dccm -d -d -b -Idcc -tCMN,5, -wwhiteclnt -llog -Uuserdirs
-SHELO -Smail_host -SSender -SList-ID
1.3.154 listening to /var/run/dcc/dccm with /var/lib/dcc
init_work=50 max_work=1348 max_max_work=1348 (RLIMIT_NOFILE limit)

3) when I send mail through my server, I see nothing in the debug output
of dccm.  I don't see any lines in the mail.log either (I even turned up
sendmail logging to level 15).  It's like sendmail is completely
ignoring the fact that it has to send stuff to this milter.

I am clamav as a milter and this is working fine.  I tried putting the
feature line above and below the clamav line in the .mc file and it made
no difference.

Suggestions how to debug this further?



More information about the DCC mailing list

Contact vjs@rhyolite.com by mail or use the form.