Cannot compile with gcc 4.8

dcc@jelmail.com dcc@jelmail.com
Fri Jun 13 11:35:26 UTC 2014


Hello,

I maintain a DCC package for the Arch Linux distribution and have just 
tried to update it to the latest version 1.3.154. I have found that I 
cannot compile it with the current gcc toolchain (version 4.8.2.8). I 
have tried to compile it with an older toolchain (4.6.3) and that works 
without issue.

The errors reported when using gcc 4.8.2.8 are shown below:

cc -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector 
--param=ssp-buffer-size=4 -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE 
-I./include -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -I../include 
-D_FORTIFY_SOURCE=2 -c -o dccif.o dccif.c
In file included from ../include/dcc_defs.h:52:0,
from dccif.c:42:
../include/dcc_socket.h:79:16: error: conflicting types for ‘sa_family_t’
typedef u_char sa_family_t;
^
In file included from /usr/include/bits/socket.h:146:0,
from /usr/include/sys/socket.h:38,
from /usr/include/netinet/in.h:23,
from /usr/include/netdb.h:27,
from ../include/dcc_types.h:67,
from ../include/dcc_defs.h:50,
from dccif.c:42:
/usr/include/bits/sockaddr.h:28:28: note: previous declaration of 
‘sa_family_t’ was here
typedef unsigned short int sa_family_t;
^
<builtin>: recipe for target 'dccif.o' failed
make[1]: *** [dccif.o] Error 1
gmake.inc:48: recipe for target 'all' failed
make: *** [all] Error 2


Any suggestions as to what the problem might be?

Thanks.







More information about the DCC mailing list

Contact vjs@rhyolite.com by mail or use the form.