DCC version 1.3.130/2.3.130 released

Vernon Schryver vjs@calcite.rhyolite.com
Thu Aug 12 17:01:45 UTC 2010


> From: Anatoly Pugachev <mator@team.co.ru>

> it's not possible to auto-update dcc via libexec/updatedcc on solaris 10
> x86, i.e. if I run it as :
>
> # cd /var/dcc ; libexec/updatedcc -xv
> ...
> + test -n  -a -d /var/lock/subsys 
> + exit 0 
>
> there's no /var/lock (and subsys) directory on solaris 10.

If there is an empty string after "test -n",
then it should not matter whether /var/lock/subsys exists.

The string "-a -d" does not occur in the current version of updatedcc
nor in the RCS logs of any previous version of updatedcc.
There is this command in rcDCC:

   if test -n "$MODULE" -a -d /var/lock/subsys

That fits your "+ test -n  -a -d /var/lock/subsys" line.
On systems without /var/log/subsys, nothing is done.


If my guess is right, then among the shell commands covered by your "..."
was probably ".../libexec/rcDCC -x start".
Depending on the contents of /var/dcc/dcc_conf
libexec/rcDCC might have tried to (re)start dccm, dccifd, or dccd.

In other words, I see nothing wrong in that fragment.

What is the symptom?  Why do you say that updatedcc does not work?
Are there error messages from updatedcc, rcDCC, or one of the DCC daemons?
Are the DCC daemons not running?


One of the systems on which I install new versions says:

    lonestar% uname -a
    SunOS lonestar 5.10 Generic_127112-06 i86pc i386 i86pc
    lonestar% cdcc -V
    2.3.130
    cdcc map> ^D


Vernon Schryver    vjs@rhyolite.com



More information about the DCC mailing list

Contact vjs@rhyolite.com by mail or use the form.