Any problem with mixed DCC versions?

Gary Mills mills@cc.umanitoba.ca
Sat Mar 29 19:41:20 UTC 2008


I probably don't even need to ask this, but I like to be careful.
I just upgraded a test server from dcc-1.3.48 to dcc-1.3.86.  On
startup, DCC noticed version mismatches and automatically upgraded
the necessary databases.  These messages appeared:

    Mar 29 12:36:53 setup01 dccd[15877]: [ID 702911 mail.error] dcc_db contains the wrong magic string "DCC checksum database version 3"
    Mar 29 12:36:56 setup01 dbclean[15879]: [ID 702911 mail.error] wrong magic in flod.map; "DCC flod map version 10" instead of "DCC flod map version 14"

It all worked normally after that.  For production, I have two DCC
servers with flood feeds to each other and to external sites that both
run dcc-1.3.48.  Can I upgrade one to dcc-1.3.86 and leave the other
one at the old version for some time?  I assume that this is all
possible.

-- 
-Gary Mills-    -Unix Support-    -U of M Academic Computing and Networking-



More information about the DCC mailing list

Contact vjs@rhyolite.com by mail or use the form.