Problem on dcc 1.3.30 - Continue Not Asking DCC...

Vernon Schryver vjs@calcite.rhyolite.com
Thu Mar 9 17:07:44 UTC 2006


> From: Gary Mills 

> > : Mar  9 09:29:38 dcc dccifd[4782]: no DCC answer from 127.0.0.1,6277 
> > after 18264 ms
> > : Mar  9 09:29:38 dcc dccifd[4782]: continue not asking DCC 64 seconds 
> > after failure
>
> I've been seeing this problem for a long time, but it doesn't happen
> every day.  It did this morning, though.  It seems to begin with
> database cleaning:

Are both of your servers known to dccifd and with the same (or no) RTT
adjustments?  If so, that should not happen.  Dccifd should switch to
the other server when one fails to answer instead of giving up asking
for exponentially increasing durations.

Is it possible that time appeared to dccifd to jump?  For example, if
Solaris stops everthing to shuffle pages of dcc_db and dcc_db.hash from
RAM to the disk, dccifd might think that it had worked hard without
any answers from dccd.


>   Mar  9 03:54:36 electra dccm[4639]: [ID 702911 mail.error] fcntl(F_SETLKW F_WRLCK resolve lock /usr/local/dcc/map 3): Deadlock situation detected/avoided

I think that is an independent problem, albeit perhaps triggered by
slowness.  I thought I had fixed it in 1.3.30, but evidently not.  I
can't reproduce it and so have been just guessing.  Oh, well, back to
code reading and theorizing.


Vernon Schryver    vjs@rhyolite.com



More information about the DCC mailing list

Contact vjs@rhyolite.com by mail or use the form.