No message body error with DCC 1.3.4

Gary V lists@johnmecham.com
Sun May 15 13:06:51 UTC 2005


Stephen wrote:

>>I set mine up with:
>>./configure --with-uid=vscan && make && make install 
>>and it works fine. 

> Thanks for the tip but after trying that it's unfortunately still the same.
> When I run spamassassin -D <testmail.txt manually as the vscan user I do not receive the error.  SA correctly finds dccproc, gets a response in the form of:
> debug: DCC: got response: X-DCC-NIET-Metrics: jupiter 1080: env_From=5 Body=1005 Fuz1=15706 Fuz2=1006
> and exits clean.
> The 'dccproc[18755]: missing message body; fatal error' message only appears when it's run via amavisd-new.
> As such, I'll try that list but if anyone else has something to suggest I'd be grateful in your ideas.
> Cheers,
> Steve

what does
su vscan 'spamassassin -D <testmail.txt' say?
and
amavisd debug-sa (use your MUA to send a test mail through during debug)

Are you running amavisd-new chrooted? Try without if you are.

Try changing both owner *and* group of the dcc installation:
chown -R vscan:vscan /path/to/dcc

Gary V




More information about the DCC mailing list

Contact vjs@rhyolite.com by mail or use the form.