No message body error with DCC 1.3.4

Stephen Carter Stephen@retnet.co.uk
Sun May 15 10:22:49 UTC 2005


>>>Gary V <lists@johnmecham.com> 05/13/05 7:55 pm >>> 

>Not an authoritative answer, but: 
>You may not need to compile with --homedir, it might contribute to 
>the cause of your problem. 
 
>I set mine up with: 
>./configure --with-uid=vscan && make && make install 
>and it works fine. 
 
>Also, you should set your MUA to wrap text at 72 characters, having to 
>scroll to the end of each line is annoying. 
 
>My 0.02 
 
Thanks for the tip but after trying that it's unfortunately still the same.

When I run spamassassin -D <testmail.txt manually as the vscan user I do not receive the error.  SA correctly finds dccproc, gets a response in the form of:

debug: DCC: got response: X-DCC-NIET-Metrics: jupiter 1080: env_From=5 Body=1005 Fuz1=15706 Fuz2=1006

and exits clean.

The 'dccproc[18755]: missing message body; fatal error' message only appears when it's run via amavisd-new.

As such, I'll try that list but if anyone else has something to suggest I'd be grateful in your ideas.

Cheers,

Steve




More information about the DCC mailing list

Contact vjs@rhyolite.com by mail or use the form.