A Weird one

Daniel V Klein dvk@lonewolf.com
Fri Jul 23 18:34:31 UTC 2004


This is very odd:

% cdcc info
# 07/23/04 12:16:07 EDT  /var/dcc/map
# Re-resolve names after 14:16:06  Check RTTs after 12:31:07
# 202.68 ms threshold, 202.68 ms average    12 total, 4 working servers
IPv6 off

dcc1.dcc-servers.net,-      anon
#   142.27.70.214,-                                  COLLEGEOFNEWCALEDONIA ID 11
89
#     100% of 15 requests ok  223.73 ms RTT            104 ms queue wait
#   194.109.153.82,-                                             NIET ID 1080
#      59% of 32 requests ok 1957.25 ms RTT           1019 ms queue wait
# * 208.201.249.232,-                                       sonic.net ID 1156
#      29% of 31 requests ok  152.68 ms RTT             53 ms queue wait

dcc2.dcc-servers.net,-      anon
#   194.119.212.5,-                                                   ID 1182
#      16% of 32 requests ok  204.25 ms RTT             60 ms queue wait
#   212.203.14.116,-                                        EATSERVER ID 1166
#      not answering

dcc3.dcc-servers.net,-      anon
#   137.118.60.88,-
#      not answering
#   216.240.97.12,-
#      not answering

dcc4.dcc-servers.net,-      anon
#   204.152.184.184,-
#      not answering
#   212.69.217.26,-
#      not answering

dcc5.dcc-servers.net,-      anon
#   62.75.136.220,-
#      not answering
#   194.85.132.210,-
#      not answering
#   208.201.249.233,-
#      not answering


This is on maxwell.ibp.com (which is 10.0.2.6 on my local network, NATed from
66.207.133.141).  On cub.ibp.com (which is 10.0.2.1 and 66.207.133.137) reports
all the public wcc machines answering.  Perversely, on maxwell I can ping most
of them and can also telnet to port 6277 on most of them (including the ones
reported as "not answering").  I have checked and rechecked my firewall, and I
don't think that is the problem.  In fact, (to go into detail) immediately
after I do a "cdcc rtt" I look at the reflexive rule for port 6277, and I
only find those things that responded (on either machine).  It is almost as
if maxwell is not trying to UDP those other machines.

Now here is the really weird part!

If I "cdcc 'delete dcc1.dcc-servers.net'", and then do a "cdcc rtt", I see:

% cdcc rtt
# 07/23/04 14:19:52 EDT  /var/dcc/map
# Re-resolve names after 16:19:52  Check RTTs after 14:34:52
# 181.33 ms threshold, 194.20 ms average    12 total, 4 working servers
IPv6 off

dcc2.dcc-servers.net,-      anon
#   194.119.212.5,-                                                   ID 1182
#      17% of 29 requests ok  208.21 ms RTT             71 ms queue wait
#   198.137.254.27,-                                            Misty ID 1170
#      33% of  3 requests ok  181.33 ms RTT            125 ms queue wait
# * 212.203.14.116,-                                        EATSERVER ID 1166
#      50% of  2 requests ok  144.20 ms RTT             43 ms queue wait

dcc3.dcc-servers.net,-      anon
#   142.27.70.214,-                                  COLLEGEOFNEWCALEDONIA ID 1189
#      25% of  4 requests ok  223.38 ms RTT            104 ms queue wait
#   194.109.153.82,-                                
#      not answering
#   208.201.249.232,-                               
#      not answering

dcc4.dcc-servers.net,-      anon
#   137.118.60.88,-                                 
#      not answering
#   207.195.195.223,-                               
#      not answering
#   216.240.97.12,-                                 
#      not answering

dcc5.dcc-servers.net,-      anon
#   62.75.136.220,-                                 
#      not answering
#   204.152.184.184,-                               
#      not answering
#   212.69.217.26,-                                 
#      not answering

If I delete dcc2.dcc-servers.net, then suddenly dcc3.dcc-servers.net answers.
It seems to be only able to handle 4 machines total.

Help?



More information about the DCC mailing list

Contact vjs@rhyolite.com by mail or use the form.