dccproc -R / -a usage question

Tod D. Ihde toon@warmerbythelake.com
Sat Jun 26 10:45:12 UTC 2004


After re-reading the documentation a few times, I'm still not able to 
correctly figure out how I'm supposed to use either the -R or -a 
command-line switches for dccproc (yes, I still use dccproc, haven't 
moved to dccifd yet).

What I want to do is use:
OK IP <ip address>
matching in my whitelist(s).

Reading the documentation for dccproc, I see that in order to use
OK IP <ip address>
in my whitelist(s), I need to use either the -R switch (telling dccproc 
that the 1st Received: line is from my mail server), or I need to use 
the -a switch with the IP address of my mail server.

With neither switch in use, dccproc correctly inserts an X-DCC header, 
but does not match on OK IP <addresses> (numeric, of course)

Here's a small excerpt of the headers of a message (incorrectly) being 
tagged as bulk:

Return-Path: <root@jesus-crispie.com>
Delivered-To: toon@warmerbythelake.com
Received: from ns1.warmerbythelake.com (localhost.localdomain [127.0.0.1])
	by warmerbythelake.com (Postfix) with ESMTP id D6DA4AACBC
	for <toon@warmerbythelake.com>; Sat, 26 Jun 2004 04:16:48 -0500 (CDT)
Received: from saviour.jesus-crispie.com (unknown [24.158.21.13])
	by warmerbythelake.com (Postfix) with ESMTP id 742D2AACBB
	for <toon@warmerbythelake.com>; Sat, 26 Jun 2004 04:16:48 -0500 (CDT)
Received: by saviour.jesus-crispie.com (Postfix, from userid 0)
	id A2C9D7C0C; Sat, 26 Jun 2004 04:16:37 -0500 (CDT)
To: toon@warmerbythelake.com
Message-Id: <20040626091637.A2C9D7C0C@saviour.jesus-crispie.com>
Date: Sat, 26 Jun 2004 04:16:37 -0500 (CDT)
From: root@jesus-crispie.com (root)
X-Virus-Scanned: by AMaViS snapshot-20020531
X-DCC-WBTLDCC-Metrics: nicodemus 1013; Body=1 Fuz1=187
Subject: [DCC SPAM] fwlogwatch ALERT: 5 packet(s) from XX.XX.XX.XX

However, when I add either the -R switch (as the 1st Received: line _is_ 
from my local SMTP agent), or the -a 24.158.21.10 (the IP of my server), 
dccproc stops adding the header to all email it processes. I also tried 
adding -d to see some debugging output in syslog, but none was produced. 
Running the same command as an unprivlidged user from the command line, 
and piping an email to it also gives the email sans X-DCC header.

I'm sure I'm just doing something silly, but I've been plugging at this 
for most of the evening, and the light bulb atop my head hasn't gone on 
yet. Can anyone give me any ideas to try to nudge me along?

Thanks!

   Tod.



More information about the DCC mailing list

Contact vjs@rhyolite.com by mail or use the form.