dccifd segmentation fault

Sune Kloppenborg Jeppesen mml@2night.dk
Mon May 24 20:15:45 UTC 2004


On Monday 24 May 2004 20:49, Vernon Schryver wrote:
> > From: Sune Kloppenborg Jeppesen
> >
> >Manual installation worked with the start-dccifd script. The odd thing is
> > that AFAIR dccifd -b -ddd -Q worked with version 1.2.28 but not with the
> > latest (using Gentoo ebuilds). So going with start-dccifd it now works!
>
> What is the difference between what you got from Gentoo and the official
> DCC releases?  What do you get from Gentoo, binaries, some source,
> only installation scripts, or something else?
Its unmodified sources with an automated install script. The script places 
some binaries in /usr/sbin and the rest in /usr/bin, logger is not installed 
and links all configuration to /etc/dcc and probably some other minor 
changes. dccifd is still seg faulting with the above paramters when running 
as root. So there is no actual support for the daemon though with my changes 
it is now working and I added a Gentoo init script for dccifd. Next step will 
be dccd:)

> `dccifd -b` is odd, because it tells dccifd to not go into the background.
Used it for debugging with the old version. Didn't get to actually use the 
version. 

> `dccifd -Q` is also unusual, because Query-mode turns off reporting
> mail to DCC servers.  If everyone ran with -Q, then the global DCC
> server databases would be empty.  I think -Q makes sense only if your
> system also runs mail through a DCC client that does not use -Q.
> There are cases where it running mail through two DCC clients is
> unavoidable, but they are rare and generally undesirable.
Also for debugging. Never really got off the ground using dccifd.

-- 
Regards

Sune Kloppenborg Jeppesen



More information about the DCC mailing list

Contact vjs@rhyolite.com by mail or use the form.