dccifd segmentation fault

Vernon Schryver vjs@calcite.rhyolite.com
Sun May 23 17:34:54 UTC 2004


> From: Sune Kloppenborg Jeppesen 

>
> I've been trying to install the latest dcc with Gentoo Portage and it have 
> been working fine so far. To optimize things a bit I tried to make 
> Spamassassin use dccifd but it results in a segmentation fault. Version 
> 1.2.28 is working fine so I wonder if any installation instructions changed 
> since back then?

Nothing significant has changed in the DCC installatation stuff since 1.2.28.

> The dccifd output I get is:
> dccifd -b -ddd -Q
> 1.2.48 listening to /var/dcc/dccifd
> max_work=190 max_max_work=190
> Segmentation fault

What is the stack trace for the core dump?


> With spamassassin -D I get this line:
> DCCifd -> check skipped:  Died 
> at /usr/lib/perl5/vendor_perl/5.8.2/Mail/SpamAssassin/Dns.pm line 632.
>
> I've been trying to update the install script according to the current 
> instructions but I still get the same result. I've googled for similar 
> problems but also to no avail. 

"Update the install script"?  That sounds ominous.  Exactly what do you mean.
As far as I know, there is nothing reasonable and likely that cannot
be done with parameters to the DCC ./configure script and perhaps
environment variables.


> The Gentoo ebuild is moving the files around a bit after install and I fear 
> that might cause the problem.

That "moving around" sounds like a bad idea, but any core dumps are
serious bugs, unless that "moving around" affects the DCC source or
standard UNIX libraries.

What I would do is:

 - fetch and unpack the current DCC source from 
      http://www.dcc-servers.net/dcc/source/dcc-dccd.tar.Z
      to ensure there are no Gentoo or other "improvements"

  - figure out where you want to put the DCC programs, man pages, 
      and so forth.  

  - `setenv DBGFLAGS=-g` or `DBGFLAGS=-g; export DBGFLAGS`

  - `./configure ...`  with your parameters

  - `make install` to build and install the DCC programs

  - configure /var/dcc/dcc_conf (or wherever you put the (new?) DCC
      home directory.  If the new DCC home directory is in the same place
      as your Gentoo stuff, compare dcc_conf and dcc_conf-new

  - start dccifd with `/var/dcc/libexec/start-dccifd`
       or `/var/dcc/libexec/rcDCC start`

  - gdb /var/dcc/core-file-name /var/dcc/libexec/dccifd
      to start the debugger

  - use the command "bt" to print the stack trace.


Vernon Schryver    vjs@rhyolite.com




More information about the DCC mailing list

Contact vjs@rhyolite.com by mail or use the form.