dccifd segmentation fault

Sune Kloppenborg Jeppesen sune@dir.dk
Sun May 23 16:32:16 UTC 2004


Hi all,

I've been trying to install the latest dcc with Gentoo Portage and it have 
been working fine so far. To optimize things a bit I tried to make 
Spamassassin use dccifd but it results in a segmentation fault. Version 
1.2.28 is working fine so I wonder if any installation instructions changed 
since back then?

The dccifd output I get is:
dccifd -b -ddd -Q
1.2.48 listening to /var/dcc/dccifd
max_work=190 max_max_work=190
Segmentation fault

With spamassassin -D I get this line:
DCCifd -> check skipped:  Died 
at /usr/lib/perl5/vendor_perl/5.8.2/Mail/SpamAssassin/Dns.pm line 632.

I've been trying to update the install script according to the current 
instructions but I still get the same result. I've googled for similar 
problems but also to no avail. 

The Gentoo ebuild is moving the files around a bit after install and I fear 
that might cause the problem.

So if you have any suggestions or hints they will be warmly welcomed.

-- 
Regards

Sune Kloppenborg Jeppesen



More information about the DCC mailing list

Contact vjs@rhyolite.com by mail or use the form.