Dccm troubles

Vernon Schryver vjs@calcite.rhyolite.com
Thu Sep 4 23:26:45 UTC 2003


> From: Dale Hege <fhege@sover.net>

> Hello, I recently started using dccm to filter our email and have found
> that dccm seems to "die" fairly frequently. I have 4 dccm servers 3 are

> ...
> One from the 4.3.1 running dccm 1.2.2

> #1  0xa008831a in abort () from /shlib/libc_s.4.3.0
> #2  0xa0089d1b in _thread_aio_entry_init () from /shlib/libc_s.4.3.0
> #3  0xa0089b14 in _thread_sys_accept () from /shlib/libc_s.4.3.0
> #4  0x804ce35 in mi_listener ()

It might be interesting to compile the milter library with -g.

> #0  0xa007e623 in _thread_aio_suspend ()
> (gdb) where
> #0  0xa007e623 in _thread_aio_suspend ()
> #1  0xa007ce8f in _thread_sys_write ()
> #2  0x804909c in log_write (wp=0x80cec10, logbuf=0x1014eda4, len=77)
>     at dccm.c:866

That's also in the bowels of the BSD/OS thread package.
I've fought bugs in BSD/OS 4.2 pthreads.  The code aint pretty,
although that applies to about any threads that make do with
select() kludges.

> But most of the time it seems to just stop running with no core. The last
> messages in the logs look like this
>
> Sep  4 18:03:10 trout dccm[22855]: 1.2.2 rejected messages to 649 targets
> and discarded messages to 0 targets among 1306 total since 09/04/03
> 17:54:01

That looks like what should happen if the sendmail milter library
gets unhappy.  Have you looked in likely syslog places for
messages from libmilter?


Aother site running BSD/OS 4.2 has presistent dccm crashes that look
like stack corruption.  The corruption always seems to be the same,
but I've not yet tried to find the stack.  It looks like a thread
tried to return through a broken frame and went into the weeds, leaving
the thread's real stack I don't know where..


Vernon Schryver    vjs@rhyolite.com



More information about the DCC mailing list

Contact vjs@rhyolite.com by mail or use the form.