invalid database address 0x23f59f7a0

Vernon Schryver vjs@calcite.rhyolite.com
Thu Nov 28 19:15:04 UTC 2002


> From: Alexander Talos <Alexander.Talos@univie.ac.at>

> I'm on aix 4.3.3 and 4.3.2, managed to compile dcc*, and had it running
> for about one day. Since, I get warnings about invalid "database address
> 0x23f59f7a0". The problem can be reproduced. There are no flod peers
> involved. I tried 1.1.13 and 1.1.16 with the same result. dblist shows:

> ...
> 11/26/02 17:03:57.480496    2        4261       delayed         eb6c8
>   Body         2          edd45fd7 29b59de1 7d28604f 86d74b55 23f59f6e0
> 71450

That's a seriously broken hash table link.

How do you reproduce it?  Is there a recipe or is it matter of waiting
for a few minutes, hours, or days?

Is NFS or some other network file system involved? 

Do you copy the file or do anything else unusual?  

Can the problem be reproduced with a smaller white list?


There once was a DCC server in the global network running on AIX 4.1.PPC.


> ...
> Just because I'm curious: what does "delayed" mean?

"Delayed" means that report will not be immediately flooded to other
DCC servers but a delayed summary will be synthesized and flooded.


Vernon Schryver    vjs@rhyolite.com



More information about the DCC mailing list

Contact vjs@rhyolite.com by mail or use the form.