Error message

Rose, Bobby brose@med.wayne.edu
Mon Sep 30 22:20:59 UTC 2002


I had already tried that a couple times.  Another thing that I just
tried was copy the whiteclnt.dccw from my test box which doesn't give
the broken pipe message to the production box and ran wlist against it
there and it gives the broken pipe message there.  If I copy the
whiteclnt.dccw to the test box, wlist doesn't give the message so it
doesn't look like corruption issue.  Could it be a difference in a
library dependency??

 

-----Original Message-----
From: Vernon Schryver [mailto:vjs@calcite.rhyolite.com] 
Sent: Monday, September 30, 2002 3:28 PM
To: dcc@rhyolite.com
Subject: RE: Error message


> From: "Rose, Bobby" <brose@med.wayne.edu>

> I have the same setup on a test box with the same lists and it doesn't

> do it.  If I run the wlist command on the test box, it looks clean but

> on the prod box, returns the same results except the last line is a 
> Broken Pipe message.

Are the two boxes running the same operating systems and versions of the
DCC software?

What happens if you delete /var/dcc/whiteclnt.dccw?

I'll change things in 1.1.15 so that instead of refusing to touch a
.dccw file with an impossible size, the DCC client library code will
delete and rebuild the file.  That's probably sufficiently safe because
the magic number (actually, magic string) has already been found in the
file.

I've heard complaints of .dccw corruption, but I've no clue how to
reproduce it or whether the problem is a bug in my code or an external
problem such a file-system overflow.


Vernon Schryver    vjs@rhyolite.com
_______________________________________________
DCC mailing list      DCC@rhyolite.com
http://www.rhyolite.com/mailman/listinfo/dcc




More information about the DCC mailing list

Contact vjs@rhyolite.com by mail or use the form.