dccproc-1.0.53 inserting "p=/home/username/.dcc/whiteclnt.dccw ..."

Chris Shenton chris@Shenton.Org
Wed Apr 17 00:32:41 UTC 2002


Built dccproc from sources and installed.  It appears to be inserting
a debugging line which confuses my MUA when I use the "-w" flag.

In the first example, a simple email message is piped, with no "-w":

chris@thanatos(268> cat /tmp/email2 |dccproc
Return-Path: <chris@thanatos.shenton.org>
Delivered-To: chris@thanatos.shenton.org
Received: (qmail 88962 invoked from network); 17 Apr 2002 00:25:05 -0000
Received: from localhost (HELO thanatos.shenton.org) (127.0.0.1)
  by 0 with SMTP; 17 Apr 2002 00:25:05 -0000
Received: (from root@localhost)
	by thanatos.shenton.org (8.12.2/8.12.2/Submit) id g3H0P5Xm088958;
	Tue, 16 Apr 2002 20:25:05 -0400 (EDT)
To: chris@thanatos.shenton.org
Subject: does maildir also have the q= stuff?
From: Charlie Root <chris@thanatos.shenton.org>
Date: 16 Apr 2002 20:25:05 -0400
X-Gnus-Mail-Source: maildir:~/Maildir/new
Message-ID: <lmbn6uji.fsf@thanatos.shenton.org>
Lines: 1
Xref: thanatos.shenton.org in.chris:20447
X-DCC-sackHeads-Metrics: thanatos.shenton.org 1012; Body=0

bar



Then I do the same but with a "-w" flag; notice the first line:


chris@thanatos(269> cat /tmp/email2 |dccproc -w /home/chris/.dcc/whiteclnt
p=/home/chris/.dcc/whiteclnt.dccw p+=is/.dcc/whiteclnt.dccw
Return-Path: <chris@thanatos.shenton.org>
Delivered-To: chris@thanatos.shenton.org
Received: (qmail 88962 invoked from network); 17 Apr 2002 00:25:05 -0000
Received: from localhost (HELO thanatos.shenton.org) (127.0.0.1)
  by 0 with SMTP; 17 Apr 2002 00:25:05 -0000
Received: (from root@localhost)
	by thanatos.shenton.org (8.12.2/8.12.2/Submit) id g3H0P5Xm088958;
	Tue, 16 Apr 2002 20:25:05 -0400 (EDT)
To: chris@thanatos.shenton.org
Subject: does maildir also have the q= stuff?
From: Charlie Root <chris@thanatos.shenton.org>
Date: 16 Apr 2002 20:25:05 -0400
X-Gnus-Mail-Source: maildir:~/Maildir/new
Message-ID: <lmbn6uji.fsf@thanatos.shenton.org>
Lines: 1
Xref: thanatos.shenton.org in.chris:20447

bar


Is this a misfeature or errant debug statement? is there a way to
disable it so my MUA doesn't get so confused?

Thanks.



More information about the DCC mailing list

Contact vjs@rhyolite.com by mail or use the form.